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THE AutoCAD WINDOWS ENVIRONMENT





�



A.  STARTING UP AutoCAD








	Start AutoCAD 2000 using the following method:





  NOTE:  This method is based on the Windows 95/98 operating system.





With Windows already started and the desktop icons displayed on the screen, double-click on the application icon named AutoCAD 2000 using the left mouse button or highlight the application icon clicking the left mouse button once and then press the Enter key.  See Windows desktop below.














�


�
 B.  THE PROGRAM WINDOW





	Now that AutoCAD has been started we will first explore the program window.  The program window consists of several parts.  Figure 1.1 below shows the layout of AutoCAD’s program window.  A brief description of each area of the display window will explain the uses of each area.








�





Figure 1.1





Menu Bar - Contains the default AutoCAD menus. Menus are defined by menu files that you can modify or design on your own. See chapter 4, "Custom Menus," in the Customization Guide. Additionally, installing third-party applications may add menus or menu commands. The default menu file is acad.mnu. To learn how to specify a different one, see "Specifying Search Paths, File Names, and File Locations."





Standard Toolbar - Contains frequently used buttons such as Redraw, Undo, and Zoom, as well as Microsoft Office standard buttons such as Open, Save, Print, and Spell. Buttons with small black triangles in the lower-right corner have flyouts containing tools that invoke commands related to the first tool shown. Click and hold down the first button to display the flyout.





Object Properties Toolbar - Sets object properties such as color, line type, and line weight and manages layers. See chapter 9, "Using the Object Properties Toolbar."





Draw and Modify Toolbars - Provide access to common draw and modify commands. The Draw and Modify toolbars are displayed when you start AutoCAD. These toolbars are docked on the left side of the window. You can easily move toolbars and turn them on and off. See chapter 2, "Working with Toolbars."





Drawing Area - Displays drawings. The drawing area size varies, depending on the size of the AutoCAD window and on the number of other elements (such as toolbars and dialog boxes) that are displayed.





Crosshairs - Identifies pick and drawing points within the drawing area. Use the crosshairs, which are controlled by your pointing device, to locate points and select and draw objects. 





User Coordinate System (UCS) Icon - Shows the orientation of the drawing. AutoCAD drawings are superimposed on an invisible grid, or coordinate system. Coordinate systems are based on X, Y, and (for 3D) Z coordinates. AutoCAD has a fixed world coordinate system (WCS) and a movable user coordinate system (UCS). To help you visualize the UCS location and orientation, a UCS icon is displayed in the lower-left corner of the drawing area. See chapter 5, "Using Coordinate Systems."





Model Tab/ Layout Tabs - Switch your drawing between model (drawing) space and paper (layout) space. You generally create your designs in model space, and then create layouts to plot and print your drawing in paper space. See chapter 15, "Creating a Layout to Plot."





Command Window - Displays prompts and messages. In AutoCAD, you start commands in one of three ways: 





(  Choose an item from a menu or a shortcut menu.


(  Click a button on a toolbar.


(  Enter the command on the command line.





However, even if you choose commands from menus and toolbars, AutoCAD may display command prompts and the command history in a command window. See chapter 4, "Using Commands and System Variables."


�
Status Bar - Displays the cursor coordinates in the lower-left corner. The status bar also contains buttons that you can use to turn on common drawing aids. These include Snap (Snap mode), Grid (drawing grid), Ortho (Ortho mode), Polar (polar tracking), Osnap (object snaps), Otrack (object snap tracking), Lwt (lineweight display), and Model (model and paper space toggle). See chapter 7, "Drawing with Precision," for more information about AutoCAD drawing aids.





C.  MENU BAR





	A quick and easy way to access control and settings for AutoCAD is to use the menu bar.  The menu bar contains commands and functions that are the heart of AutoCAD.  Menu bar options do three basic functions:  





		1st - Issues a command that the user has to input information.





		2nd - Display additional menus.





		3rd - Display a box that allows you to change settings.





		The following pages contain a brief overview of the menu bar menus and the AutoCAD commands associated with them:





"FILE MENU"





�


�
"EDIT MENU"


�





"VIEW MENU"





�








"INSERT MENU"





�











"FORMAT MENU"





�


�






"TOOLS MENU"














�


�









"DRAW MENU"

















�





�















"DIMENSION MENU"

















�


�
"MODIFY MENU"














�


�












"WINDOW MENU"
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"HELP MENU"
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D.  PULL-DOWN MENUS PRACTICAL EXERCISE





1.  Move your arrow cursor to the Tools pull-down menu and press the left mouse/pick button.  Now move your mouse to the bottom of this cascading menu and select the Options… menu by picking it with the left mouse button.  Figure 1.2 below is the dialog box that appears on your screen.  This dialog box contains the commands and settings that allow you to change AutoCAD's environment.








�


	





Figure 1.2








2.  This box has several "Pages" indicated by the tabs at the top.  These tabs contain settings that control how AutoCAD looks on your screen as well as many other settings.  The following is a brief listing of the options and settings available on these tabs:





Files tab:  Search paths, file names, and file locations





Display tab:  Window Elements, Layout elements, Crosshair size, Display resolution, Display performance, and Reference Edit fading intensity





Open and Save tab:  File Save, File Safety Precautions, External References (Xrefs), and Object ARX Applications





Plotting tab:  Default plot setting for new drawings, General plot options, and Default plot style behavior for new drawings





System tab:  Current 3D Graphics Display, Current Pointing Device, General Options, and dbConnect Options





User Preferences tab:  Windows Standard Behavior, AutoCAD Design Center, Hyperlink, Priority for Coordinate Data Entry, Object Sorting Methods, and Lineweight Settings





Drafting tab:  AutoSnap Settings, AutoSnap Marker Size, AutoTrack Settings, Alignment Point Acquisition and Aperture Size





Selection tab:  Selection Modes, Pickbox Size, Grips, and Grip Size





Profiles tab:  Available profiles    





	3.  Pick the Open and Save tab located near the top of this dialog box.  





	4.  In the File Safety Precautions tile, pick your left mouse button and hold it down.  While holding your left mouse button down, drag it over the number 120 located below the Automatic save area of this tile, then release the left mouse button.  The number 120 should be highlighted blue.  





	5.  Type 10 and press the Enter key or pick the OK tab with your left mouse button.  When the command is complete you will have changed the time of AutoCAD's auto file save feature from 120 minutes to 10 minutes.�
E.  AutoCAD TOOLBARS





	Pull-down menus give you control of the general operation of AutoCAD.  Toolbars do the work of creating new objects and editing existing ones.  For example, the Modify toolbar allows you to modify objects in a drawing.  The Draw toolbar allows you to create new ones.  In the Toolbars there are icon buttons that allow you to perform one of three actions.





		1st - They issue commands that require keyboard or cursor input.


		2nd - They display further options.


		3rd - They open dialog boxes.





	Toolbars contain icons that represent commands.  Each icon has tool tips that help you understand them.  Move the cursor to the toolbar icons and leave it there for a second.  The command's name appears.  This is the tool tip.  At the bottom of the screen is the status line.  A description of the buttons purpose also appears.  See Figure 1.3.





�





Figure 1.3





	AutoCAD's toolbars are very mobile.  A docked toolbar is locked into placed.  Docked means it is placed against the top, bottom, or side borders of the AutoCAD window.  Toolbars can be moved to any location.  When this is done, it is then an undocked toolbar.  The following is a list of the toolbars available from the View pull-down Toolbars… menu:





3D Orbit			Dimension			Draw


Inquiry			Insert				Layouts


Modify				Modify II			Object Properties


Object Snap			Refedit			Reference


Render			Shade				Solids


Solids Editing		Standard Toolbar		Surfaces


UCS				UCS II				View


Viewports			Web				Zoom





The Standard, Object Properties, Draw, and Modify toolbars are displayed by default.	





F.  TOOLBARS PRACTICAL EXERCISE





	1.  Move the arrow cursor so it points to the vertical bars, called grab bars, to the far left of the Object Properties toolbar.  See Figure 1.4.





�





Figure 1.4





	2.  Press and hold down the left mouse button.  Notice that a gray rectangle appears by the cursor.





	3.  Still holding down the left mouse button, move your mouse cursor down.  The gray box follows.





	4.  Move the gray box a short distance down in the drawing area and release the mouse button.  The Object Properties toolbar, now a floating toolbar, moves to the new location.


	5.  To place the toolbar back to its docked position, move the arrow cursor on to the toolbar’s title bar (use Object Properties), pick the left mouse button, and hold it down.  Now drag the toolbar so it is in position in the upper-left corner of the drawing window.  





	6.  When the toolbar is near its’ docked position release the left mouse button.  The toolbar is now "Docked".





	Using this technique, all of AutoCAD's toolbars can be moved and reshaped and placed where you want them.  They can be put away when not in use and brought back when you need them.








G.  FLYOUTS





	Most icons start commands as soon as they are selected.  Others display additional icons that relate to the tool selected.  These are called flyouts.  Flyouts are identified by a small black pointing arrow located in the lower right corner of the icon button.





�








H.  FLYOUTS PRACTICAL EXERCISE





	1.  Move to the Zoom Window icon � on the Standard toolbar.  Pick and hold down the left mouse button to display the flyouts.  Do not let go of the left mouse button.


	


	2.  While holding down the left mouse button, move the arrow down or up to see the tool tips appear.  A description at the bottom of the AutoCAD window also appears.  Move your arrow cursor to a blank space in the drawing area and release the left mouse button.








�
I.  FUNCTION KEYS





	AutoCAD uses function keys, also called F keys, which are located along the top of your keyboard.  These keys allow you to toggle on or off certain functions while using AutoCAD commands.  Below is a list of AutoCAD’s function keys.





		Key		Action





		F1		Invokes Help


		F2		Calls up the AutoCAD text window


		F4		Toggles on/off tablet mode


		F5		Cycles between isoplane modes


		F6		Toggles on/off the coordinate display mode


		F7		Toggles on/off grid display


		F8		Toggles on/off ortho mode


		F9		Toggles on/off snap mode


		F10		Toggles on/off polar mode








J.  OPENING A FILE PRACTICAL EXERCISE





	At this point we are ready to start working with AutoCAD.  First open an existing file.  This will familiarize you with some of the operations.         





	1.  Pick File from the menu bar.  Pick Open….  A Select File dialog box appears on your screen.





	2.  To the far left under the words Select File is Look in:.  The directory Acad2000 is displayed to the right of Look in: Below that is a white rectangular box displaying Acad2000 subdirectories.  





	3.  Move the arrow to the Sample subdirectory and double click it with the left mouse button.  The subdirectory name Sample is now displayed to the right of Look in: and the white rectangular box displays the contents of the Sample directory.





	4.  Move the arrow to the file named 1st floor architectural and click it.  Notice that the 1st floor architectural drawing is displayed in the Preview box.





	5.  Click the Open button at the bottom of the Select File dialog box.  AutoCAD opens the 1st floor architectural file, as shown in Figure 1.5.


  


Note:  Previous versions of AutoCAD drawing files will not appear in the Preview box unless they are saved in release 2000 format.
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K.  SAVING A FILE PRACTICAL EXERCISE





	Periodically it is wise to save your file as you work.  Your work can be saved under its original title with the File > Save command, or a different name with the File > Save As… command.  Doing File > Save As creates a new drawing file.





	By system default settings, AutoCAD saves your file every 120 minutes.  Previously you changed this time to every 10 minutes.  This time can be increased or decreased by the user.  AutoCAD saves your file to a name of Auto.SV$.  This file must be renamed into the AutoCAD.dwg format before it can be opened.


  


	From the File pull-down menu pick Save.  If the file is unnamed the Save Drawing As dialog box appears on your screen.  In the Save Drawing As dialog box, type in the new drawing name.  Then pick the Save button.








L.  CLOSING AutoCAD





	After all work has been completed on one drawing, you can open another drawing or close AutoCAD.  To close and exit AutoCAD use the Exit option in the File pull-down menu.  If your drawing has been modified you will be prompted to save changes to your work, choose Yes, No or Cancel.  See Closing AutoCAD practical exercise for detailed information.








M.  CLOSING AutoCAD PRACTICAL EXERCISE





	1.  Pick File > Exit, from the pull-down menu.  A dialog box appears on your screen prompting you to "Save changes to" and offers three options;  Yes, No and Cancel.





	2.  Pick the No button.  AutoCAD exits and does not save changes.





Note:  When any changes have been made to a drawing and the Exit command is chosen, this inquiry box will always appear.  This is a safety feature that allows you to change your mind and save your drawing before you exit AutoCAD.





**To save your drawing in AutoCAD Release 12,13 or 14 format, see below.
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